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5 Szövegfolyatás

Az Adobe InDesign program lehetőséget ad rövid szövegdarabok keretbe folyatására, illetve 
a szövegfolyatás alatt keretek létrehozására, valamint keretek és oldalak hozzáadására. Ezzel 
egyszerűen folyathatunk szöveget dokumentumainkba – legyen az szórólaptól kezdve a maga-
zinon át az e-könyvig bármi.
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A lecke áttekintése
Ebben a fejezetben a szövegfolyatással ismerkedünk meg, és az alábbi lépéseket fogjuk elsajátítani 
eközben:
•	 Szöveg importálása és folyatása meglévő szövegkeretbe
•	 Bekezdésstílusok alkalmazása
•	 Sortörések igazítása
•	 Keretek manuális létrehozása szövegfolyatás közben
•	 Keretek automatikus hozzáadása szövegfolyatás közben
•	 Szövegkeretek automatikus átméretezése
•	 Láncolt keretek automatikus létrehozása
•	 Oldalak és láncolt keretek automatikus hozzáadása szövegfolyatás közben
•	 Folytatás megjegyzés hozzáadása a szöveg folytatásának jelölésére
•	 Hasábtörések hozzáadása

Ez a lecke körülbelül 45 percig fog tartani.

Elindulás
Ebben a leckében egy magazin félig kész cikkén fogunk dolgozni. A cikk nyitó oldalpárjának dizájnja 
már majdnem teljesen elkészült, számos oldalon már csak a szöveget kell elhelyezni.

A cikken véghezvitt módosításokat elvégezve megismerkedünk a szövegfolyatás különböző módjaival, 
és folytatás megjegyzést hozunk létre a szöveg folytatásának jelölésére.

1	 Annak érdekében, hogy az Adobe InDesign CS6 preferenciái és alapbeállításai megegyezzenek a lec-
kében használtakkal, az Elindulás fejezet Alapbeállítások fájl mentése és visszaállítása részében leírt fo-
lyamatot követve helyezzük át az InDesign Alapbeállítások (Defaults) fájlt egy másik mappába.

Megjegyzés: Ha még nem töltöttük a merevlemezre a www.perfactkiado.hu/mellekletek oldalról az 
Adobe InDesign CS6 Tanfolyam a könyvben letölthető leckeállományait, tegyük meg most. Lásd A Tanfolyam 
a könyvben állományainak letöltése részt az Elindulás fejezetben.

2	 Indítsuk el az Adobe InDesign CS6 alkalmazást. Ahhoz, hogy a panelek és a menüpontok ponto-
san megegyezzenek a leckében használtakkal, válasszuk ki a Window > Workspace > [Advanced] 
(Ablak > Munkaterület >[Speciális]), majd a Window > Workspace > Reset Advanced (Ablak > 
Munkaterület > Speciális visszaállítása) menüpontot.

3	 Kattintsunk a File > Open (Fájl > Megnyitás) parancsra, majd nyissuk meg a merevlemezünk 
Lesson_05 mappájában található 05_Start.indd állományt.

4	 Válasszuk ki a File > Save As (Fájl > Mentés másként) menüpontot, adjuk a fájlnak a 05_Flow-
Text.indd nevet, és mentsük el a Lesson_05 mappába.

5	 Ha látni szeretnénk, hogyan fest majd a kész dokumentum, nyissuk meg az ugyanebben a map-
pában található 05_End.indd állományt. (Jelen esetben ez a dokumentum nem teljesen egyezik 
a végső tervezéssel, mivel sokkal több képet, feliratot és dizájnelemet fogunk hozzáadni a doku-
mentumhoz.) Útmutató gyanánt munkánk során nyitva hagyhatjuk ezt a dokumentumot is.
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Megjegyzés: Ha a dokumentumban lévő képek nagyon életlennek tűnnek, válasszuk ki a View > Display Per-
formance > High Quality Display (Nézet > Megjelenítési minőség > Kiváló minőségű megjelenítés) menüpontot.

6 Amikor készen állunk a lecke dokumentumán végzendő munkára, kattintsunk a dokumen-
tumablak bal felső sarkában található fülére.

Szövegfolyatás meglévő keretbe
Amikor importálunk egy szöveget, új vagy már meglévő keretbe folyathatjuk. Ha a keret üres, a be-
töltött szöveg ikonnal a keretbe kattintva abba folyathatjuk a szöveget. A cikkünk nyitó oldalpárjá-
nak bal oldalán lévő üres, „Local Stats” alcímű keretes írásba az oldalon látható nő bemutatása kerül. 
Ebbe a keretbe egy Microsoft Word-dokumentumot fogunk importálni, bekezdésstílust alkalmazunk 
rá, majd kipróbáljuk az árvasorok kijavításának két módját. (Árvasoron ebben a példában azt értjük, 
hogy egy sor egyetlen szóból áll.)

      Tipp: Amellett, hogy a Microsoft Word szövegszerkesztőhöz hasonló programokból importálunk (vagy he-
lyezünk el) fájlokat, Adobe InCopy és Adobe Buzzword formátumú fájlokat is elhelyezhetünk dokumentu-
munkban. Az Adobe Buzzword a csoportmunkát megkönnyítő, előfizetéses formában elérhető, online szö-
vegszerkesztő alkalmazás.

1     Ha szükséges, nagyítsunk rá a nyitó oldalpár bal oldalán található keretes írás szövegkeretére. 
Ellenőrizzük, hogy egyetlen objektum se legyen kijelölve.

Szöveg szerkesztéséhez a Szöveg eszközt, szövegkeretek láncolásához a Kijelölés eszközt használ-
juk, szöveg importálásakor azonban teljesen mindegy, hogy milyen eszköz van kiválasztva.

2 Kattintsunk a File > Place (Fájl > Elhelyezés) menüpontra. Ha szükséges, kattintsunk a Place pár-
beszédablak alján lévő Show Import Options (Importálási beállítások megjelenítése) és Create 
Static Options (Rögzített feliratok létrehozása) jelölőnégyzetekbe.

3 Keressük meg a Lesson_05 mappában a 05_LocalStats.docx állományt, majd kattintsunk rá 
duplán.
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Az egérmutató betöltött szöveg ikonra ( ) változik, s megjeleníti az elhelyezésre váró szöveg első 
néhány sorát. Ha a betöltött szöveg ikont egy üres keret fölé helyezzük, az ikon zárójelbe kerül ( ).

4	 Vigyük a betöltött szöveg ikont a helykitöltő szövegkeretre (a „Local Stats” alcímet tartalmazó 
szövegkeret alá).

5	 A szöveg elhelyezéséhez kattintsunk.

6	 Ahhoz, hogy szerkeszteni tudjuk a szöveget, kattintsunk a keretbe a Szöveg eszközzel ( ). A keret 
teljes szövegének kijelöléséhez válasszuk ki az Edit > Select All (Szerkesztés > Minden kijelölése) 
menüpontot.

7	 A Paragraph Styles (Bekezdésstílusok) panel megnyitásához kattintsunk a Type > Paragraph Styles 
(Szöveg > Bekezdésstílusok) menüpontra.

8	 Kattintsunk a White Sidebar Text bekezdésstílusra. (Ha szükséges, a stílus megkereséséhez gör-
gessünk lefelé a Paragraph Styles panelen.)

Tipp: A helyi felülírások törlésének, és ezáltal a stílusnak megfelelő szövegformázás visszaállításának egyik 
módja, ha a Paragraph Styles panelmenüjéből kiválasztjuk a Clear Overrides (Stílus törlése) menüpontot. 
A stílusokról a 9. leckében tudhatunk meg többet.

A bekezdésstílus neve mellett megjelenő pluszjel (+) a helyi felülírást (a bekezdésstílustól eltérő 
változatot) jelzi, mivel a kijelölt szöveg egy része félkövéren van szedve. A helyi felülírások sokszor 
kerülendők, most azonban nem okoznak gondot számunkra.

A következő lépésekben a harmadik, az „Occupation” szóval kezdődő bekezdés árvasorát fogjuk 
kijavítani sortörés kézi beszúrásával.

9	 Nagyítsunk rá a szövegre, hogy jól olvasható legyen.
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10	 Válasszuk ki a Szöveg eszközt, és kattintsunk a keret harmadik bekezdésének „Urban” szava elé. 
Az „Urban” szó következő sorba küldéséhez nyomjuk le a Shift és Enter (Windows), illetve 
a Shift és Return (Mac OS) billentyűket.

Tipp: Amennyiben elfelejtjük a kézi sortörés billentyűparancsát, válasszuk ki a Type > Insert Break Character 
>Forced Line Break (Szöveg > Töréskarakter beszúrása > Szándékos sortörés) menüpontot.

Az utolsó sorban lévő árvasort a betűközt módosítva javítjuk ki. A betűközzel a kijelölt karakte-
rek közötti távolságot fogjuk megváltoztatni.

11	 Ha szükséges, görgessünk le az utolsó, „Favorite Meridien memory” szöveggel kezdődő bekezdés-
hez, hogy jól lássuk. A teljes bekezdés kijelöléséhez kattintsunk rá négyszer egymás után a Szöveg 
eszközzel.

12	 A Character (Karakter) panel megjelenítéséhez válasszuk ki a Type > Character menüpontot. Gé-
peljünk –10-et a Tracking (Betűköz) mezőbe, majd üssük le az Enter, illetve a Return billentyűt.

13	 Válasszuk ki az Edit > Deselect All (Szerkesztés > Kijelölés megszüntetése) menüpontot, majd 
kattintsunk a File > Save (Fájl > Mentés) parancsra.

Tipp: Ha a Szöveg eszközbe több szövegfájlt töltöttünk be, billentyűzetünk kurzorbillentyűivel válthatunk a behelye-
zendő szövegfájlok között, és az Esc billentyű leütésével távolíthatunk el szövegfájlokat a betöltött szöveg ikonból.

Több szövegfájl betöltése a Szöveg eszközbe

A Place párbeszédablakban több szövegfájl egyidejű betöltésére, majd egyesével történő elhelyezé-
sükre is lehetőségünk nyílik. A Szöveg eszköz betöltése a következőképpen működik:
•	 Először is nyissuk meg a File > Place menüponttal a Place párbeszédablakot.
•	 A Ctrl (Windows), illetve a Command billentyű (Mac OS) lenyomva tartása mellett kattintva 

több, nem szomszédos fájlt is kijelölhetünk.
•	 A Shift billentyű lenyomott állapotában kattintva fájlok folyamatos sorát jelölhetjük ki.
•	 Amikor az Open gombra kattintunk, a betöltött szöveg ikon zárójelben jelzi a betöltött fájlok szá-

mát, például (4).
•	 A fájlokat külön-külön kattintással tudjuk elhelyezni.
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15 E-könyv létrehozása
és exportálása

Az Adobe InDesign CS6 olyan új és továbbfejlesztett EPUB-fájlexportálási funkciókkal ren-
delkezik, amelyek megkönnyítik az elektronikus eszközökön, táblagépeken és okostelefonokon 
olvasható e-könyvek létrehozását.

One Truly  
Amazing 

Truly 
Amazing 

Truly 
Meal
Amazing 
Meal
Amazing 

1

A Four-Course Dinner  
Fit For royAlty
by PAt smith

A  C u l i n A r y  b e s t  s e l l e r
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A lecke áttekintése
A lecke során egy InDesign-dokumentumot hozunk létre, majd exportáljuk elektronikus olvasóesz-
közökön megtekinthető EPUB-fájlként. Munkánk során az alábbi területekkel foglalkozunk:
•	 A dokumentum befejezése úszó képek hozzáadásával, a bekezdés- és karakterstílusok exportcím-

kékre képezésével és a tartalomjegyzék létrehozásával
•	 Az exportált EPUB-fájlba kerülő tartalom kiválasztása, valamint a tartalom sorrendjének átrendezése
•	 Metaadatok hozzáadása az InDesign-dokumentumhoz és az EPUB-fájlhoz
•	 EPUB-fájl exportálása és előnézete

A lecke körülbelül 45 percig tart.

Elindulás
Az előttünk álló leckében elvégezzük az utolsó simításokat egy recepteket tartalmazó füzeten, EPUB-
fájlként exportáljuk a dokumentumot, végül megtekintjük az exportált fájl előnézetét.

Megjegyzés: Ha még nem töltöttük le a merevlemezre a www.perfactkiado.hu/mellekletek oldalról az 
Adobe InDesign CS6 Tanfolyam a könyvben letölthető leckeállományait, tegyük meg most. Lásd A Tanfo-
lyam a könyvben állományainak letöltése részt az Elindulás fejezetben.

Megjegyzés: A könyv írása idején az Amazon Kindle nem támogatja az EPUB szabványt, de saját Kindle-for-
mátumára konvertálja az elküldött EPUB-fájlokat.

Megjegyzés: Ugyan egyes eszközök támogatják a rögzített elrendezésű EPUB-fájlokat, aktuális leckénkben 
nem foglalkozunk az ilyen típusú állományokkal.

Tipp: A lecke végén EPUB-fájlt exportálunk. Az EPUB-fájlok és más digitális kiadványok megtekintéséhez és 
kezeléséhez használhatjuk az Adobe Digital Editions szoftver windowsos vagy Mac OS-es változatát. 
Az Adobe Digital Editions ingyenesen letölthető az Adobe weboldaláról (www.adobe.com).

Mivel az elektronikus kiadványok bizonyos szempontból alapjaiban különböznek nyomtatott társaik-
tól, munkánkat megkönnyítendő érdemes elolvasni az alábbi, az EPUB-fájlokkal kapcsolatos alapve-
tő információkat.

Annak érdekében alakították ki az EPUB szabványt, hogy a kiadók az .epub formátumot támogató 
bármilyen elektronikus olvasóeszközzel és -szoftverrel – ezek közé tartozik például a Barnes & Noble 
Nook, a Kobo eReader, az Apple iBooks for iPad, az iPhone, a Sony Reader és az Adobe Digital Edi-
tions szoftver – megjeleníthető, újratördelhető tartalmat tudjanak létrehozni. Mivel az e-olvasók kép-
ernyőjének mérete eszközönként eltérő, és a tartalom egyetlen folyamatos szövegkeretláncba kerül, az 
InDesign-dokumentumnak nem kell konkrét képernyőmérethez alkalmazkodnia. Ezért használjuk 
a leckében az – angolszász területen – szabványos 8,5×11 hüvelykes oldalméretet.

1	 Annak érdekében, hogy az Adobe InDesign CS6 preferenciái és alapbeállításai megegyezzenek 
a leckében használtakkal, az Elindulás fejezet Alapbeállítások fájl mentése és visszaállítása részében 
leírt folyamatot követve helyezzük át az InDesign Alapbeállítások (Defaults) állományt egy másik 
mappába.

2	 Indítsuk el az Adobe InDesign CS6 alkalmazást. Ahhoz, hogy a panelek és a menüpontok ponto-
san megegyezzenek a leckében használtakkal, válasszuk ki a Window > Workspace > [Advanced] 
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(Ablak > Munkaterület >[Speciális]), majd a Window > Workspace > Reset Advanced (Ablak > 
Munkaterület > Speciális visszaállítása) menüpontot.

3 Kattintsunk a File > Open (Fájl > Megnyitás) parancsra, majd nyissuk meg a merevlemezünk 
Lesson_15 mappájában található 15_Start.indd állományt.

4 Azért, hogy lássuk, miként fest majd a kész dokumentum, nyissuk meg az ugyanebben a mappá-
ban található 15_End.indd fájlt.

5 Navigáljunk végig a füzet oldalain, hogy megszemlélhessük a borítóoldalt, illetve az azt követő 
négy receptet.

6 Ha megtekintettük, zárjuk be a 15_End.indd fájlt – de útmutató gyanánt nyitva hagyhatjuk ezt 
a dokumentumot is.

7 Válasszuk ki a File > Save As (Fájl > Mentés másként) menüpontot, adjuk az állománynak 
a 15_RecipesBooklet.indd nevet, majd mentsük el a Lesson_15 mappába.

A füzet befejezése
Néhány utolsó simításra van még szükség ahhoz, hogy a dokumentumot EPUB-fájlként lehessen ex-
portálni. Először hozzáadunk a füzethez néhány képet, amelyeket aztán úszó képként helyezünk el 
a szövegben, majd olyan bekezdésstílussal formázzuk az úszó képeket tartalmazó bekezdéseket, amely 
automatikusan oldaltöréseket hoz létre az exportált EPUB-fájlban. A füzetet egyszerű tartalomjegy-
zék létrehozásával és metaadatok hozzáadásával tesszük teljessé.

Úszó képek hozzáadása

A receptfüzet négy receptet tartalmaz: egy előételét, egy főételét, egy zöldségételét és egy desszertét. 
A recepteket egyetlen láncolt szövegkeret foglalja magában. Az egyes fogások képét a címük elé rög-
zítjük, majd olyan bekezdésstílust rendelünk a szöveghez, amelyet oldaltörések létrehozására fogunk 
használni az exportált EPUB-fájlban. Azért, hogy a lehető legegyszerűbb dolgunk legyen, a képfájlo-
kat könyvtárban tárolták el számunkra.

One Truly  
Amazing 

Truly 
Amazing 

Truly 
Meal
Amazing 
Meal
Amazing 

1

A Four-Course Dinner  
Fit For royAlty
by PAt smith

A  C u l i n A r y  b e s t  s e l l e r
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1	 Válasszuk ki a File > Open (Fájl > Megnyitás) menüpontot, és nyissuk meg a Lesson_15 mappá-
ban lévő 15.Library.indl fájlt.

2	 A Pages panel segítségével, vagy a Ctrl+J (Windows), illetve a Command+J (Mac OS) billentyű-
ket leütve, majd a Page (Oldal) mezőbe 3-at beírva, és végül az OK gombra kattintva menjünk 
a 3. oldalra.

Megjegyzés: A szövegben úszó képek lehetővé teszik, hogy az exportált EPUB-fájlban szabályozzuk a szö-
veghez viszonyított helyzetüket.

3	 Helyezzünk a Szöveg eszközzel ( ) szövegbeszúrási pontot a „Guacamole” címsor elé, azután üs-
sük le az Enter, illetve a Return billentyűt.

Tipp: Ha gondoljuk, az ebben a leckében elvégzendő munkához megjeleníthetjük az olyan rejtett karaktere-
ket, mint a sortörések és a szóközök. Ehhez válasszuk ki a Type > Show Hidden Characters (Szöveg > Rejtett 
karakterek megjelenítése) menüpontot.

4	 Húzzuk a Kijelölés eszközzel ( ) az „Avocados.tif ” nevű könyvtárelemet az oldal melletti munka-
területre.

5	 A Shift billentyű lenyomva tartása mellett húzzuk a képkeret jobb felső sarokba közelében lévő 
kék téglalapot a 3. lépésben létrehozott üres sorba. Akkor engedjük fel az egér gombját, amikor 
rövid, függőleges vonal jelenik meg a címsor felett. A képkeret soron belüli úszó képpé változott, 
amely az őt körülvevő szöveggel együtt folyik.

Tipp: Könyvtárelemek soron belüli képként történő beszúrásához úgy is eljárhatunk, hogy létrehozzuk a szö-
vegben a beszúrási pontot, kijelöljük a Library panelen az elemet, majd kiválasztjuk a Library panelmenü Pla-
ce Item(s) (Elem[ek] elhelyezése) menüpontját. Az elem automatikusan beillesztődik soron belüli képként.

6	 Kattintsunk a Szöveg eszközzel az úszó képtől balra vagy jobbra, létrehozva egy beszúrási pontot.

7	 Nyissuk meg a Paragraph Styles (Bekezdésstílusok) panelt: válasszuk ki a Type > Paragraph Styles 
(Szöveg > Bekezdésstílusok) menüpontot, vagy kattintsunk a dokkolt panelek listáján a Parag-
raph Styles szavakra.

8	 A bekezdésstílusokat felsoroló listán a Graphics stílusra kattintva rendeld ezt az úszó képet tartal-
mazó, egysoros bekezdéshez.

Amikor a lecke későbbi részében exportáljuk az EPUB-fájlt, a Graphics bekezdésstílussal fogjuk 
négy különálló (HTML) fájllá bontani a négy receptet. A hosszú dokumentum kisebb darabokra 
bontása hatékonyabbá teszi az EPUB-fájl megjelenítését, és azt eredményezi, hogy minden recept 
új oldalon kezdődik.

9	 A 4–8. lépéseket megismételve rögzítsük a másik három könyvtárelemet (Salmon.tif, Asparagus.tif 
és Strawberries.tif ) a kapcsolódó receptek címsora elé. Ne feledjünk el minden képkeret után sortö-
rést tenni, illetve a Graphics bekezdésstílust rendelni a keretet tartalmazó egysoros bekezdéshez.

10	 Mentsük el munkánkat (Fájl > Save).
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Úszó képek exportálási beállításainak testreszabása

Az EPUB-fájlok exportálása során az objektumokra, így például a képekre érvényes általános expor-
tálási beállítások mellett a procedúrát megelőző egyedi beállításokat is megadhatunk a konkrét objek-
tumoknak. A most következő gyakorlatban a négy úszó kép egyedi exportálási beállításait fogjuk 
meghatározni.

1	 Navigáljunk a 3. oldalra.

2	 Jelöljük ki a Kijelölés eszközzel az Avocados.tif képet tartalmazó képkeretet.

3	 Válasszuk ki az Object > Object Export Options (Objektum > Objektum exportálási beállításai) 
menüpontot.

4	 Nyissuk le az Object Export Options párbeszédablak EPUB And HTML (EPUB és HTML) fülét.

5	 Kapcsoljuk be a Custom Rasterization (Egyéni konverzió) jelölőnégyzetet, válasszuk ki a Size 
(Méret) menüből a Relative To Page Width (Oldalszélességhez viszonyított) beállítást, a �������Resolu-
tion (ppi) menüből pedig a 150-es felbontást.

Tipp: A Size menü Relative To Page Size beállítása gondoskodik arról, hogy a kép az e-olvasó szélességének 
megfelelően méreteződjön át, ne pedig rögzített méretű legyen.

6	 Hagyjuk megnyitva az Object Export Options párbeszédablakot, és navigáljunk a másik három 
soron belüli képre. Jelöljük ki őket egyenként, azután ismételjük meg az 5. lépést.

7	 A Done (Kész) gombra kattintva zárjuk be a párbeszédablakot.

8	 Válasszuk ki a File > Save menüpontot.

Bekezdés- és karakterstílusok leképezése exportcímkékre

Az EPUB HTML-alapú formátum. EPUB-fájlunk exportálás alatti formázását szabályozandó, a be-
kezdés- és a karakterstílusokat HTML-címkékre és -osztályokra képezhetjük le. A most következő 
gyakorlatban HTML-címkékre képezzük le a dokumentum néhány bekezdés- és karakterstílusát.

1	 Válasszuk ki a Type > Paragraph Styles menüpontot, vagy kattintsunk a dokkolt panelek oszlopá-
ban a Paragraph Styles fülre.

2	 Válasszuk ki a Paragraph Styles panelmenüből az Edit All Export Tags (Összes exportcímke szer-
kesztése) parancsot.
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